Plugins for Automate & Labtech will be attending the Automation Nation on this June 18-20, 2018. Click here to learn more!
Cart 0

PowerShell Plugin Now Pushes WMF 5.1

Automate powershell upgrades Manage powershell versions Update PowerShell

PowerShell Plugin Now Pushes WMF 5.1

The P4A team recently received some requests from clients to start pushing Powershell 5.1 out to agents as part of our automation processes. We are happy to announce that we have now incorporated WMF 5.1 for the following OSes.

Windows 8, Windows Server 2012 and Windows Server 2012 R2.

Windows Management Framework (WMF) 5.1 brings functionality that has been updated from WMF 5.0. WMF 5.1 is available for installation only on Windows Server 2012 R2, Windows Server 2012, Windows 2008 R2 SP1, Windows 8.1, and Windows 7 SP1. Some of the new and updated features in this release include: 

  • Constrained file copying to/from JEA endpoints
  • JEA support for Group Managed Service Accounts and Conditional Access Policies
  • PowerShell console support for VT100 and redirecting stdin with interactive input
  • Support for catalog signed modules in PowerShell Get
  • Specifying which module version to load in a script
  • PowerShellGet cmdlet support for proxy servers
  • Improvements in PowerShell Script Debugging
  • Improvements in Desired State Configuration (DSC)
  • Improved PowerShell usage auditing using Transcription and Logging

For more information on our PowerShell plugin for ConnectWise Automate visit our POSH Plugin Product Page


Older Post Newer Post


Leave a comment